
Procedure for Creating a Printed Circuit Board 
From Ultiboard 9 to the LPKF ProtoMat C20 
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Before You Begin 
In order to use the LPKF ProtoMat C20 circuit board plotter, you must first do the following: 

1. Complete a training session for the LPKF circuit board plotter with the EE/CE 
Technician 

2. Schedule a time with the EE/CE Technician to use the machine 
Please use the LPKF circuit board plotter for project and class work only. If you desire a 
circuit board for personal use, please speak with the EE/CE Technician to obtain special 
approval. 
 
Please read this procedure carefully, follow all steps precisely, and observe the 
correct sequence. 
If at any point during this procedure you are unsure how to proceed, please do not 
guess. Instead, ask the EE/CE Technician for assistance. 
 
Stage 1: Exporting from Ultiboard 9 
A) Prepare Ultiboard 9 to Export 

1. Open your project in Ultiboard 9 
2. Under the “Options” menu, select “Global Preferences” 
3. Select the “PCB Design” tab 
4. Ensure that “Post Processing” → “Show Fiducial Marks” is not checked 

This prevents Ultiboard from exporting hash marks and other information that is not 
actually part of the board design. 

5. Click “OK” 
6. (Optional) You may wish to double-check your project’s trace and hole sizes using 

actual components prior to completing the export process 
There is a trace and hole size testing board available in F256 for this purpose. 
Consult the EE/CE Technician for assistance. 

B) Export Your Project’s Board Data in Gerber X Format 
1. Choose “File” → “Export” 
2. Select “Gerber RS-274X” 
3. Click “Properties” 
4. Transfer the Board Outline, Copper Bottom, and Copper Top to the “Export Layers” 

box 
If your board design does not use a top layer, only transfer Board Outline and 
Copper Bottom. 



5. Check that the other settings are as follows: 
Units Imperial (mil) 
Digits Integer = 2, Decimal = 5 
Oversize All boxes should be unchecked 
Options All boxes should be unchecked 
 
Correct any settings that are set otherwise 

6. Click “OK” 
7. Click “Export” 

A dialog box called “Create Aperture Mapping” will appear for each layer exported, 
one after another. After that, a “Save Export File” box will appear. Follow steps 8-
10 for each layer. 

8. For each aperture in the “Apertures not yet set” table, perform the following steps: 
a. Select (highlight) the aperture line in the table 
b. Click “Assign to DCode” 
c. Click “OK” 

This will assign the aperture to the next available Gerber X DCode. The 
numbering of the DCodes is not important because a table relating DCodes 
to aperture sizes gets exported along with your file. 

9. When the “Apertures not yet set” table is empty, click “OK” 
10. Choose a save location for your file and click “Save” 

For the sake of convenience in following this procedure, it is best not to modify the 
file name automatically generated by Ultiboard. The automatic naming is as 
follows: 
Board Outline = “Project(File) - Board Outline.gbr” 
Copper Top = “Project(File) - Copper Top.gbr” 
Copper Bottom = “Project(File) - Copper Bottom.gbr” 

C) Export Your Project’s Drill Data in NC Drill Format 
1. Choose “File” → “Export” 
2. Select “NC Drill” 
3. Click “Properties” 
4. Set the options as follows: 

Units Imperial 
Digits Integer = 2, Decimal = 5 

5. Click “OK” 
6. Click “Export” 

Two save dialog boxes will appear, one right after the other. 



7. Choose a save location for your file and click “Save” 
For the sake of convenience in following this procedure, it is best not to modify the 
file name automatically generated by Ultiboard. The automatic naming is as 
follows: 
NC Drill File: “Project(File) Copper Top-Copper Bottom.drl” 
Drill Info (Drill List): “Project(File) Drill Info.rep” 
Repeat step 7 for each file. 

 
Stage 2: Importing to CircuitCAM 
A) Open CircuitCAM 

1. Copy your files onto a network drive or portable media (floppy disk, usb drive, CD, 
etc.) 

2. Log in to the computer in F256 attached to the LPKF circuit board plotter 
F256 is the room between F254 and F266 where PCB and prototyping equipment 
is located. 

3. If you are using removable media, connect it to the LPKF circuit board plotter 
computer at this time 

4. On this computer, open CircuitCAM by double clicking the “CircuitCAM 5.0” icon on 
the desktop 

B) Import the Board Outline 
1. On the “File” menu select “Import” 
2. Navigate to your board outline Gerber X file and select “Open” 

Remember, by default this filename is in the form: 
Project(File) - Board Outline.gbr 

3. At the dialog box, change the following options: 
File Type Pulldown Menu GerberX 
Layer Pulldown Menu BoardOutline 
All other settings will be autodetected 

4. In the “List of Apertures” text pulldown box, create a name for the Board Outline’s 
aperture list 
The name does not matter, but it should be unique. The simplest name to use is 
the name of the layer, i.e. “BoardOutline.” 

5. Click “Preview” to verify that the board outline looks correct 
6. Close the preview window 
7. Click “Import” 

C) Import Copper Traces and Drill Data Using the Wizard 
1. Click the “Wizard Window” button 

This small button has a wand on it and is located in the same button set as “Open,” 
“Save,” etc. Clicking this button will switch you to the Wizard view. 



2. Follow the instructions in the Wizard to import your copper traces: 
a. Import your “Copper Top” Gerber X file for the “Layout Top Side” 

Note: Even if you have a single-sided board, you must still do this step. If 
that is the case, use the Board Outline as your top side Gerber X file.  

b. Import your “Copper Bottom” Gerber X file for the “Layout Bottom Side” 
3. When you get to the “Drilling Data” section of the Wizard, import your “Copper Top-

Copper Bottom.drl” NC Drill file 
Your drill info file (“Drill Info.rep”) should be imported automatically and 
transparently at the same time. 

4. Continue the Wizard until you get to “Contour Routing” 
5. Now, instead of clicking “Next”, exit the Wizard view by clicking the “Graphic Mode” 

button 
 
Stage 3: Using CircuitCam to Prepare Your Milling Job 
A) Perform Contour Routing and Place Break-out Tabs 

This part of the procedure allows you to create tabs which will hold the board in place 
after the edges have been milled. The effect is similar to that used for components of 
plastic hobby models. 

1. Click the “Contour Routing” button.  
This button is large and has a red arrow pointing at a solid maroon rectangle. 

2. Set the options as follows: 
Outside/Inside  Outside 
Layer "BoardOutline” (not “Bottom Layer”) 
Destination Layer "CuttingOutside" 
List LpkfCuttingTools 
Tool Contour Router 2.0 mm (79 mil) 
Automatic checkbox unchecked 
Gap Width 1 mm 

3. Click “Run” 
After a few moments, a thick yellow line will appear around the edge of the board. 
This is the projected cutting path for the board outline. 

4. Insert a breakout tab using the following procedure 
a. Select the thick yellow line that now follows the board outline 
b. Use the “+” and “-” keys on the keyboard to move the star shape to the 

location where you want to place a breakout tab 
c. Click the “Breakout Tab” button (next to the “Contour Routing” button) to 

place a breakout tab at the location of the star 
5. Repeat step 4 for each tab you would like to place 

Usually it is best to place two or at most three breakout tabs evenly spaced around 
the board. (Two are sufficient for almost all boards.) Too few breakout tabs will 
make the board flimsy while the machine is trying to mill the edge, while too many 
will make the board very difficult to remove from the material which it is cut from. 



6. Save your circuit by selecting “File” → “Save” 
Choose a file name that makes sense. Unlike in Ultiboard, in this case the default 
name most likely will not make sense. This step is important because 
CircuitCAM often crashes during part B below. 

B) Create Insulation 
1. Return to the Wizard view by clicking the “Wizard Window” button 
2. Follow the Wizard steps until the Wizard finishes insulation. All options will need to 

be set for both the top layer and the bottom layer. Also, note the following 
guidelines: 

a. Unless you absolutely need all extra copper removed from your board, 
select the “Without complete copper removal (only surrounding insulation 
channels)” option when prompted for an insulation method. 

b. For most jobs, you should use the following tools to insulate: 
Standard: Universal Cutter 0.2 mm (8 mil) 
Big: End Mill 1.0 mm (39 mil) 

c. When the wizard prompts you for the insulation width, usually a value 
between 1.0 mm and 2.0 mm is sufficient. 
The default value is 0.2 mm, which is usually not sufficient. 

d. A value of 2.0 mm for extra insulation around flashed pads is usually 
sufficient, but if you are concerned with high-power or high-voltage traces 
you may use a larger value. 
Again, the default value of 0.3 mm here will not be sufficient. 

e. If you are unsure about any step in the process, do not guess. Ask the 
electrical technician for help. 

3. Continue the Wizard until you get to the “Save CAM” screen 
 
C) (Optional) Add Target Holes to Your Project 

If you are milling a precision double-sided board and wish to double-check the front-to-
back alignment of your project during the milling procedure, then you will need to 
complete this step. If you are milling a single sided board or a board that does not require 
precise alignment, then skip this step. 

1. Click the “Graphic Mode” button to exit the Wizard view 
2. Follow part A of the Target Holes procedure located in Appendix C 
3. When you have finished adding the target holes, click the “Wizard Window” button 

to resume the Wizard 
D) Export Your Circuit To Board Master Format 

1. Click “Next” in the Wizard to get to the export screen, saving your project when 
prompted 

2. Select “LpkfCircuitBoardPlotter” from the dropdown list 
3. Click “Next” to export the CAM. 



4. The output file will be a Board Master (.LMD) file in the same folder where you 
saved the CircuitCam (.CAM) file, and with the same base name as the CircuitCam 
file 

5. Close CircuitCam when you are finished 
 
Stage 4: Using Board Master to Execute Your Milling Job 
A) Tracking Your Tool Usage 

1. Open Windows Explorer 
2. Navigate to the folder called “C:\LPKF50\BMaster\” 
3. Locate the file in this folder called “FR4-20.tol” 

This is a tool usage record file. More specifically, this is the tool usage record file 
which corresponds to our particular circuit board plotter and board type. In order to 
properly calculate tool usage, you will need to “snapshot” this file before and after 
you run your milling job. 

4. Copy the file “FR4-20.tol” to a location of your choice and rename the copied file to 
“Before.tol” (or something similar) 
Be careful to copy, not move, the file. Renaming the copied file to “Before.tol” 
will allow you and the EE/CE Technician to determine later which is the “before” 
snapshot and which is the “after” snapshot of the tool usage record file. 

B) Setting Up The Material 
1. Open Board Master by double clicking the icon on the Desktop 
2. Select “Go To” menu → “Pause” 

The machine will move to the pause position, which will allow you to access the top 
of the machine to place the copper material. 

3. If there is not one there already, place a piece of copper board over the white 
underlay material, pressing it firmly onto the set pins 
This copper board will be cut to create your printed circuit board. If you are using a 
one sided board, make sure the copper side is up. 

4. Using masking tape, secure the board tightly to the machine table so that it is flat 
and there are no air gaps between the copper board and the unerlay material 
Be sure to place the tape so that it will not interfere with the milling head. If the 
milling head rests on tape during milling and not the copper board’s surface, then 
the milling bits will not cut to the correct depth. 

5. Define the size of the material in Board Master: 
a. Using the menus, select “Configuration” → “Settings...” and make sure 

“inch” is the unit of measurement 
When you click “OK,” the machine head will move automatically to the 
exchange position. Be sure the milling table is clear of obstructions. 

b. Next, select “Configuration” → “Material” → “Size…” and enter these values: 
Low Corner  X = 0.75 Y = -4.5 
High Corner X = 12.75 Y = 4.5 
Size will be calculated automatically. It should be X=12, Y=9 



c. Click “OK” 
A darker gray patch representing the board will appear. 

C) Preparing Your Circuit Job 
1. Select “File” → “Import” → “LMD / LPR...” 
2. Navigate to the file you exported from CircuitCam and click “Open” 

If you receive an error message, please see the EE/CE Technician. 
3. If prompted by a dialog box for a name, enter a name and click “OK” (Sometimes 

the default name doesn't work... it is too long or contains spaces or whatever. If 
that happens, Board Master will ask you to change the name.) At this point, your 
circuit will appear. 

4. Click the “Position Project” button 
This button has two rectangles: one is yellow, one is gray. When the mouse is over 
it, the status bar at the bottom of the screen says “Enables the moving of instance 
of project by mouse.” 

5. Click and drag the project to an unused portion of the copper board 
Try to use the copper base material efficiently, but do not place your project too 
close to an edge or a previous project. 
DO NOT place the project over either of the two set pins holding the copper 
board. Doing this will cause the machine to cut into those set pins, damaging both 
your board and the machine. 
DO NOT place the project outside of the boundaries of either the copper board 
(dark gray) or the useable area of the machine tabletop (light gray). Use only the 
area where the two gray rectangles overlap. Otherwise, the machine will not be 
able to properly mill the board. 

6. Verify the placement of your project on the board by moving the machine head 
over each corner of your project and visually inspecting for adequate clearance 

7. At this point, you may desire to save your project as a JOB file in the location of 
your choice 
In the event that the Board Master program (or Windows) crashes, this JOB file will 
help you and the technician start where you left off instead of starting all over 
again. 

D) Running the “MarkingDrills” Phase 
1. Select “1. MarkingDrills” from the Phase Selection box 

The Phase Selection box is to the left side on the lowest toolbar at the top of the 
screen. It contains a list of numbered phases. We will not use every phase. 

2. Click the “All +” button to select the entire phase to be active 
3. Click the “Start/Stop” button to begin the phase 

The computer will prompt you to insert the correct tool and the machine will move 
to the exchange position. 

4. Insert the proper tool, carefully following the procedure outlined in Appendix A 



5. If you need to perform a bit depth calibration for this tool, complete the following 
steps: 
You will need to calibrate the bit depth of milling (surface) tools the first time you 
use them and subsequently any time the bit depth is changed. In some cases, the 
EE/CE Technician may preset the bit depth for you, in which case you will not need 
to perform a calibration. Check with the EE/CE Technician to see if this is the case. 

a. Select the “Stop after tool exchange for adjustment” radio button 
b. Click “OK” 
c. Referencing Appendix B, perform a bit depth calibration for the tool you 

have just inserted 
d. Click the “Start/Stop” button to begin milling the phase 

As the software has already prompted you to insert the proper tool, the 
machine will now begin to mill the marking drill phase automatically. 

e. Proceed to step 7 below 
6. If you did not to perform a bit depth calibration, simply click “OK” after you have 

finished changing the tool 
The machine will begin to mill the marking drill phase automatically. 

7. When the phase is complete, click “OK” in the dialog box that appears 
E) Running The “DrillingUnplated” Phase 

1. Select “4. DrillingUnplated” from the Phase Selection box 
2. Click the “All +” button to select the entire phase to be active 
3. Click the “Start/Stop” button to begin the phase 

The computer will prompt you to insert the correct tool and the machine will move 
to the exchange position. 

4. Insert the proper tool, carefully following the procedure outlined in Appendix A 
5. When you are done changing the tool, click “OK” 

The machine will begin to drill the phase automatically. 
6. Each time the machine asks for a new tool, insert the correct tool and click “OK” 
7. When the phase is complete, click “OK” in the dialog box that appears 
8. If necessary, perform the following steps to deburr the copper on both sides of the 

base material 
Deburring involves removing any copper burrs around drill holes which stick up and 
might interfere with the milling operation. Normally, this will only be necessary if 
you are milling a double-sided board. 

a. Send the machine to the pause position by selecting “Go To” → “Pause” 
b. Remove the copper base material 
c. Use a Scotch-Brite or similar non-metallic pad to remove any burrs or raised 

edges on all copper surfaces of the base material 
d. Replace and secure the copper material in exactly the same location that 

you just picked it up from 



F) Running The “MillingBottom” Phase 
1. Select “5. MillingBottom” from the Phase Selection box 
2. Click the “All +” button to select the entire phase to be active 
3. Click the “Start/Stop” button to begin the phase 

The computer will prompt you to insert the correct tool and the machine will move 
to the exchange position. 

4. Insert the proper tool, carefully following the procedure outlined in Appendix A 
5. If you need to perform a bit depth calibration, do it now 

See part D above and Appendix B for information on performing a bit depth 
calibration. 

6. When you are done changing or calibrating the tool, click “OK” 
The machine will begin to mill the phase automatically. 

7. Each time the machine asks for a new tool, insert the correct tool and click “OK” 
Remember to recalibrate bit depth as necessary (see Appendix B). Since you are 
in the middle of the phase, DO NOT click “All +” again after this calibration. (Doing 
so would cause you to restart the entire phase.) 

8. When the phase is complete, click “OK” in the dialog box that appears 
9. Send the machine to the pause position by selecting “Go To” → “Pause” 
10. Remove the copper base material, flip it over, and replace it 

Flip the material over widthwise, so that the position of your project has changed 
front-to-back but not left-to-right. Consult the following diagram: 

This is necessary because the next two steps cut from the other side of the base 
material. 

11. Tape the board back down securely using masking tape after flipping it over 
G) Running The “MillingTop” Phase 

1. Proceed with this phase only if you have a double-sided board; otherwise, move on 
to part H 
(Single-sided boards have no milling on the top to complete.) 

2. Double-check to ensure that there are no burrs or raised edges on the board where 
your project will be milled 
If you notice any burrs or raised edges you will need to complete (or redo) the 
deburring process outlined in part E. 



3. Select “7. MillingTop” from the Phase Selection box 
You will notice that the location of the project has changed to reflect the way you 
flipped the board. 

4. (Optional) Perform a front-to-back alignment using part B of the Target Holes 
procedure in Appendix C 
You should complete this step only if you also completed part C of stage 3 above. 
This will correct any offset in the project placement between the two sides of your 
board. 

5. Click the “All +” button to select the entire phase to be active 
If you performed step 4 you may wish to instead add all traces except the target 
holes to be active 

6. Click the “Start/Stop” button to begin the phase 
The computer will prompt you to insert the correct tool and the machine will move 
to the exchange position. Alternatively, when the machine knows it already has the 
proper tool, it will just begin milling the phase when you click “Start/Stop,” in which 
case you will not need to complete step 7 below. 

7. Insert the proper tool, carefully following the procedure outlined in Appendix A 
8. If you need to perform a bit depth calibration, do it now 

See part D above and Appendix B for information on performing a bit depth 
calibration. 

9. When you are done changing the tool, click “OK” 
The machine will begin to mill the phase automatically. 

10. Each time the machine asks for a new tool, insert the correct tool and click “OK” 
Remember to recalibrate bit depth as necessary (see Appendix B) 

11. When the phase is complete, click “OK” in the dialog box that appears 
H) Running The “CuttingOutside” Phase 

1. Select “9. CuttingOutside” from the Phase Selection box 
At this point, if you did not complete part G, you will notice that the location of the 
project has changed to reflect the way you flipped the board. If you completed part 
G, there will be no further change. 

2. Click the “All +” button to select the entire phase to be active 
3. Click the “Start/Stop” button to begin the phase 

The computer will prompt you to insert the correct tool and the machine will move 
to the exchange position. 

4. Insert the proper tool, carefully following the procedure outlined in Appendix A 
5. When you are done changing the tool, click “OK” 

The machine will begin to mill the phase automatically. 
6. Each time the machine asks for a new tool, insert the correct tool and click “OK” 
7. When the phase is complete, click “OK” in the dialog box that appears 

I) Finishing Your Project 
1. Send the machine to the exchange position by selecting “Go To” → “Exchange” 



2. Remove the last tool that you used and put it away, using Appendix A as a 
reference 

3. Send the machine to the pause position by selecting “Go To” → “Pause” 
4. Remove the copper base material from the machine 

A common problem you may encounter is difficulty lifting the copper base material 
off the positioning pins. The easiest way to pry the copper board up is to insert the 
back of the tweezers between the board and the underlay material very close to the 
pin and lift. If the pin comes out with the board, please replace the pin in its proper 
location and press it firmly into place using the special set pin plunger. Consult the 
EE/CE Technician for assistance in finding and using this special tool. 

5. Verify that everything looks correct on your circuit board 
6. Close Board Master 

You should not need to save the job file, because you are finished with the job. 
However, you may save it if you like. 

7. Click “OK” when you get the message “Machine’s head will move to reference point 
when you press the button!” 
This will place the machine head in motion, moving it to the exchange position. Be 
sure the machine’s tabletop is clear before clicking “OK”. 

8. Twist or cut your board out of the base material at the breakout tabs 
9. Finish tracking your tool usage: 

a. Open Windows Explorer 
b. Navigate to the folder called “C:\LPKF50\BMaster\” 
c. Locate the file called “FR4-20.tol” 
d. Copy the file “FR4-20.tol” to a location of your choice and rename the copied 

file to “After.tol” (or something similar) 
e. Transfer the files “Before.tol” and “After.tol” electronically to the EE/CE 

Technician 
Email is a good method for doing this. The EE/ CE Technician will use these 
two files to calculate your tool usage, which will then be reported back to you 
after you have finished your project. 

f. Measure your board dimensions and report them to the EE/CE Technician 
If you email the .tol files, simply include dimension information in the email 
as well. 

10. Clean up your work area before you leave 
a. Close the Plexiglas doors of the LPKF circuit board plotter box 
b. Turn off the lamp above the LPKF circuit board plotter 
c. Log out of the computer 
d. Put away all tools and materials 
e. Clean up any dust, debris, or board scraps 

 
You’re finished! 



Appendix A: Changing Tools 
This appendix explains how to insert and remove tools (milling, drilling, and routing bits) when 
working with the LPKF ProtoMat C20 circuit board plotter. If this is your first time changing 
a tool, please ask the EE/CE Technician for assistance. 
 
A) Inserting a tool 

Follow this portion of the procedure whenever you are prompted by Board Master to insert 
a tool. 

1. If this is your first time changing a tool, request assistance from the EE/CE 
Technician 

2. Locate the tool you need among the available tools in the clear plastic case 
This case is located in the LPKF Milling Machine Tools drawer. If you are unsure 
which tool is required, do not guess. Ask the EE/CE Technician. If the tool you 
need is not available in the case, consult the EE/CE Technician for assistance. 

3. Using the tool tweezers located in the drawer, remove the tool from the plastic case 
4. Insert the tool into the machine head 

a. If the dust door is closed, open it first 
b. When inserting the tool, push it as far up into the machine head as possible 

If you do not push the tool in all the way, you risk damage to the machine. 
When drill bits are not inserted all the way, they hang down far enough to 
collide with the edge of the board and snap off. When milling tools are not 
inserted all the way, they hang down far enough to operate at an incorrect 
milling depth. Such a depth may both dull the tool and damage your board. 

c. When inserting the tool, do not touch the tool tip with your finger 
Body oils on your finger can damage the cutting edges of the tool. To 
minimize this possibility, use an object other than your skin directly to push 
the bit. The back of your fingernail and the tool tweezers both work well. 

5. Tighten the set screw which holds the tool in place 
Tighten only finger tight; do not overtighten. 

6. Slide the dust door on the machine shut to cover the tool 
This will allow the automatic vacuum system to perform correctly. 

7. Continue with your milling project until the tool needs to be removed 
B) Removing a tool 

Follow this portion of the procedure any time you need to remove a tool which is currently 
equipped in the machine head. 

1. Move the machine head to the exchange position, if it is not already there 
Remember to clear the table top prior to any machine movement. 

2. Open the dust door to allow access to the tool 



3. If the set screw is not facing forward, rotate the shaft manually to gain access to 
the set screw 
This can be accomplished by pushing with the tweezers against one side of the 
shaft until a small rotation occurs, then repeating. Do not attempt to rotate the shaft 
by gripping or moving the equipped tool. 

4. Loosen the set screw approximately 1 turn 
As you loosen the screw, watch that the tool does not fall out. Keep a fingernail or 
some object underneath the tool to catch it if it slips, or hold it in place with the 
tweezers. 

5. Remove the tool using the tweezers 
Grip above the cutting surfaces of the tool and pull downward gently until the tool is 
free. A vacuum effect may cause the tool to stick slightly, but slow movement will 
overcome this effect. 

6. Replace the tool in the plastic tool case 
Please put the tool back in the location where it originally came from. 



Appendix B: Setting Bit Depth 
This appendix explains in detail how to calibrate bit depth for the LPKF ProtoMat C20 circuit 
board plotter. If this is your first time calibrating the bit depth, please ask the EE/CE 
Technician for assistance. 
 
Prior to milling with any milling (surface) tool used by the LPKF circuit board plotter, the 
milling head must be set to the correct depth. There are several reasons for this: 

• Improper bit depths can cause incorrect trace widths to be milled 

• Improper bit depths will greatly increase wear on the milling bits, causing them to fail 
prematurely 

• Improper bit depths can cause both visual and functional surface blemishes in the 
finished circuit board 

The bit depth must be calibrated if any of the following situations occur: 

• You are beginning a new circuit board 

• An old tool has just been replaced with a new one 

• The copper board has been changed since the last bit depth calibration 

• The milling head depth has been changed since the last bit depth calibration for a 
particular tool (i.e. the height was set for a different tool) 

• You are milling a board with precision traces and you have just changed to a milling 
tool 

Please use common sense when evaluating whether or not the milling bit depth needs to be 
recalibrated. If in doubt, ask or err on the side of caution (i.e. perform a recalibration). 
 
A) Setting Universal Cutter Bit Depth 

This applies to the “Universal Cutter” tool. This tool is conical; it will mill a tapered hole. 
Thus, the hole will exhibit an inner and outer diameter with respect to the copper board 
surface. The ideal inner diameter of this hole is 8 mil. 

1. Ensure that your project is open in Board Master, or at least that a blank project is 
loaded and the board dimensions have been set 

2. Ensure that the “Universal Cutter 0.2 mm (marking)” tool is both selected in Board 
Master and installed in the LPKF circuit board plotter 

3. Move the milling head to a blank, unused portion of the board 
4. Manually drill a single test hole in the board surface: 

a. Press the “Head Motor On/Off” button to turn on the head motor 
b. Press the “Head Down” button to drill a single hole 

If you accidentally have the “8 mil” version of the Universal Cutter selected 
instead of the “marking” version, then you will need to press the “Head 
Down” button a second time in order to lift the head back up. 

c. Press the “Head Motor On/Off” button a second time to turn the motor back 
off 



5. Move the milling head out of the way so that the area above the test hole is clear 
6. Using a flashlight and the eyepiece supplied with the LPKF circuit board plotter, 

determine the inner diameter of the test hole 
The small lines visible in the eyepiece are 1 mil increments; the larger lines are 10 
mil increments. 

7. Compare the actual inner diameter with the target diameter of 8 mil 
8. Adjust the height of the milling head accordingly: 

a. Loosen the set screw at the side of the milling head by approximately ½ turn 
b. Rotate the set wheel right to move the milling head position up (reduce the 

diameter), left to move the milling head position down (increase the 
diameter) 
The wheel should click as you turn it. Every four clicks will change the hole 
diameter by approximately 1 mil. 

c. Tighten the set screw 
The screw should be snug, but not overtightened. Avoid stripping or 
damaging the set screw. 

9. Return to step 3 and repeat steps 3-8 until the correct inner hole diameter of 8 mil 
is reached. 
 

B) Setting End Mill Depth 
This applies to the “End Mill 1.0 mm” tool. This tool is cylindrical. Thus, the hole will not 
exhibit variation with bit depth. The correct bit depth must be approximated 
experimentally. 

1. Ensure that your project is open in Board Master, or at least that a blank project is 
loaded and the board dimensions have been set 

2. Ensure that the “End Mill 1.0 mm (39 mil)” tool is both selected in Board Master 
and installed in the LPKF circuit board plotter 

3. Move the milling head to a blank, unused portion of the board 
4. Manually mill a short test path on the board surface: 

a. Press the “Head Motor On/Off” button to turn on the head motor 
b. Press the “Head Down” button 
c. Using the arrows and distance box, move the machine head 0.1” in a 

direction of your choice 
d. Press the “Head Down” button a second time to move the machine head 

back up 
e. Press the “Head Motor On/Off” button a second time to turn the motor back 

off 
5. Move the milling head out of the way so that the area above the test path is clear 



6. Compare the depth of the test path to the depth of a path on a reference board 
using a dental pick or similar tool 
The goal is to get a relatively shallow path while still allowing the tool to effectively 
remove all the copper underneath it. If there is copper remaining in the path 
followed by the tool, then it is too shallow. If there is a significant drop from the 
copper board surface into the path, then it is too deep.  

7. Adjust the height of the milling head accordingly: 
a. Loosen the set screw at the side of the milling head by approximately ½ turn 
b. Rotate the set wheel right to move the milling head position up, left to move 

the milling head position down 
The wheel should click as you turn it. 

c. Tighten the set screw 
The screw should be snug, but not overtightened. Avoid stripping or 
damaging the set screw. 

8. Return to step 3 and repeat steps 3-7 until the depth of the path is set to your 
satisfaction 

 
In order to keep things tidy and compact while performing bit depth calibration, it is useful to 
move the milling head by a fixed amount (such as 6”) out of the way, then offset it by 0.1” 
prior to moving it back to create the next test hole or path. You can do this by using the arrow 
buttons in Board Master to move the milling head instead of using the mouse. This prevents 
you from using more board space than necessary to perform the calibration procedure. 



Appendix C: Ensuring Correct Front-to-Back Project Alignment using Target Holes 
This appendix explains how to use the “targetholes_40.cam” file and target holes procedure 
to ensure accurate alignment of your project during the milling process. It is based almost 
entirely on a How-To application note published by LPKF. 
 
When double-sided boards are milled using the LPKF circuit board plotter, it is possible that 
during the process of flipping the board the project will become shifted (offset) slightly from its 
correct position as interpreted by Board Master and the control hardware. The amount of 
offset is usually small, but can be significant if the project requires precision holes and traces. 
LPKF has documented a method for measuring and correcting this offset during the board 
production process, thus eliminating alignment errors in the resulting board. That method is 
outlined here. 
 
A) Adding the Target Holes to Your Project 

Perform this part of the procedure just prior to exporting your project to Board Master 
format. After you perform this procedure you should make no further changes to your 
project prior to exporting it. 

1. Open your project if it is not already open 
At this point, all importing, routing, insulation, etc. should already be completed. 

2. Click on the board outline in the lower left corner of the drawing 
Make sure you select the board outline, not the cutting outside path. Otherwise, the 
target holes will not be positioned quite correctly. 

3. With the board outline selected (highlighted), select “Edit” → “Set Zero Point” (or 
use the SHIFT+N shortcut) 
This will set the reference for the point (0,0) with respect to the board outline, 
allowing proper placement of the target holes. 

4. Open the file entitled “targetholes_40.cam” in the “C:\LPKF50\” folder via “File” → 
“Open” 
Do not close your current project file. 

5. While viewing the “targetholes_40.cam” file, select the entire drawing 
This will look like six drill holes surrounded by small rings. 

6. Right click with the mouse on the selection and select “Copy” 
7. Close “targetholes_40.cam” 

If asked to save changes, choose “No”. 
8. Back at your original project, right click and select “Paste” 

The six target holes should appear just outside your board outline at the bottom 
edge of your project. 

9. Proceed with exporting your drawing to Board Master 



B) Using the Target Holes to Ensure Accurate Alignment 
Perform this part of the procedure just after you have flipped your board and before 
performing any milling work on the top side of the board. All milling work on the bottom 
side of the board must be complete before you perform this part of the procedure. 

1. Select the “Milling Top” phase if it is not already active 
The Marking Drills, Drilling Unplated, and Milling Bottom phases should already be 
complete, and the board should be positioned with the top side up. 

2. Zoom in on the project until you can clearly see the target holes just outside the 
board outline 

3. Using the line/arc selection button, select the circle around the first hole in the 
project 
Select only this circle; no others. 

4. Click the “+” (plus) button 
This will add this circle to the list of paths to be milled. 

5. Click “Start” 
a. Insert the proper tool when prompted 

Reference Appendix A for information about changing tools. 
b. Click “OK” 

The machine will mill this single circle, then stop. 
6. Send the machine to the pause position via “Go to” → “Pause” 
7. Examine the hole and ring through the scope to determine if the project is offset in 

the X or Y direction: 
a. Adjust your view such that it resembles the following diagram: 

Remember that the view through the scope is 180 degrees out of phase with 
the board, as shown.  
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b. Measure values A, B, C, and D 
c. Compute the X offset as follows: 

2
DCX offset

−
=  



d. Compute the Y offset as follows: 

2
BAYoffset

−
=  

e. If either the X or Y offset is non-zero, then the project position needs to be 
adjusted 

8. Clear the machine table top of equipment, etc 
9. With the mouse cursor positioned over the project in Board Master, click the right 

mouse button 
This will open the placement window for the project. 

10. Add the X and Y offsets calculated in step 7 to the X and Y coordinates of the 
project origin, then click “OK” 
This will correct the project position to compensate for the measured offset. 
Remember to observe proper sign addition when working with negative offset 
values! 

11. Repeat steps 3-10 for subsequent target holes until the offsets become zero 
At the end of this step you will have adjusted the board position to nullify any 
offsets which occurred during the process of flipping the board. After completing 
this step you should not remove the board from the set pins until the Milling Top 
phase is complete. Otherwise, your calibration may be lost. 

12. Continue milling your project where you left off (at the Milling Top phase) 


