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Using GIMP to edit your web photos

Intention
So, you have GIMP installed on your computer, you need to make a quick change to an image for some 
project, but don't want to learn about computer graphics right now in order to get the image changed. 
Totally understandable. GIMP is a powerful image manipulator with many optons and tools. However, it 
is quick and somewhat intuitve (afer a tme) for the small jobs as well. Hopefully, these quickies will 
help you with your quick problem and help you to stay friends with GIMP and ready for its more 
complex tools and methods later, when you have the tme and inspiraton. 

All you should need to know to start here is how to fnd your image and open it. File -> Open. 

Change the Size of an Image (Scale)

Problem: you have a huge image and you want to put it nicely for viewing on a web page. GIMP is a 
quick soluton. 

The frst thing that you might notce is that GIMP opens the image at a logical size for viewing. So, if your 
image is really big (like the sample image) it will display it zoomed out untl it fts nicely. You can tell if 
GIMP has done this by the percentage number in the ttle bar. (you can click on the litle screenshot to 
see the full view of the screenshot) Just because it looks right in this "View" doesn't mean anything. 
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The other thing to look at in the ttlebar is the mode. If it says RGB in the ttle bar, you are fne. If it says 
Indexed or grayscale there, you should read the Change the Mode Quickie. 

Image entry in the menu and the sub menu from the screenshot should reveal itself. Click on "Scale 
Image...". When ever you click an opton from the menu that has ... behind it, expect another dialog. 
This tme, you should get the "Scale Image Dialog". 

If you have a desired width, put it in the dialog at the top where it says "New Width". If you don't have 
such a number in mind, you can steal the width of GIMP's default image size, which is 256 pixels. This is 
demonstrated in this screenshot. You can see the image that this scale dialog produced here. 

Perhaps you want your image to look more like a 4x6 inch photo on most image rendering web 
browsers. Simply switch the units to "inches" and put 4 inches in the height box (optng for smaller than 
4x6 rather than bigger). You can see this dialog here. The image this dialog produced here. 

Let GIMP choose the other dimension length for you. Meaning, it will take more image knowledge to 
change both width and height and have it look correct. So only change one and let GIMP change the 
rest. To change the other length see the crop quickie. 

Make jpegs Smaller

You can make your jpegs smaller without changing the pixel width of the image. Actually you can change 
the weight of the image a lot. I used an(other) image from APOD. The original image is huge (3000 pixels 
wide) so I also made a smaller (pixel width) image available. To prepare this image for the web, you 
should frst reduce the image to a beter width and height for web viewing as described in the scale 
quickie. Right click on the properly scaled image and follow the menus <Image> File -> Save As.... The 
Save Dialog will pop up. 

I generally type the flename I want into the text box, but the Extension drop menu can tell you the 
available fle formats (depending on the libraries you have installed and the conditons of the image you 
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are trying to save). If GIMP complains right now, or if "JPEG" is grayed out in the Extensions menu you 
should just cancel out of everything and step through the Change the Mode Quickie. 

In the JPEG Save Dialog, you can opt for GIMP defaults which reduce the size quite a bit, without hurtng 
the visual quality in a way that I can detect. This would be the safest and quickest thing to do. 

If you would like to make it smaller stll, make sure that the "Preview" toggle is on and then watch the 
image area and change the compression level by moving the "Quality" slider down. You can see the 
quality of the image changing, especially towards the lefmost end of the slider. Here is a screenshot of 
me doing this very thing. As you can see, very small is also very bad. I have a screenshot of me setng 
the Quality slider to a more acceptable level here. 

I have not been showing the actual jpegs I created so that we could end this quickie with a race. Clicking 
this page should "race" these jpegs to a web page (the frst tme you see an image in most browsers, you 
are also waitng for it to write to the cache, so the frst tme is the worst). With my cable modem, I was 
unable to see a diference in the load tme, but the diference in what you actually see is fairly 
interestng. 

Crop An Image

Many reasons to need to crop an image. Making rectangles square, or making squares into rectangles. 
Cutng alot of useless background to bring out the subject beter. etc. To get to the crop tool, you can 

either push the buton on the toolbox or right click on the image and follow the menu <Image> 
Tools -> Transform Tools -> Crop & Resize. This will change the cursor and allow you to click and drag a 
rectangular shape. The buton in the toolbox is the nicest way to get to any of the tools. I have chosen 
one of the huge and beautful APOD images, ngc6369 heritage. 
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I always click on the approximate upper lef corner and drag to the lower right corner. You don't need to 
worry about being accurate on this frst swipe with the crop tool, since a litle dialog will pop up and you 
can make a beter choice for your new borders there.. 

Afer completeing the click and drag moton, a litle "Crop & Resize Informaton Dialog" (shown above 
also) pops up, telling you informaton about the borders that were defned in the click and drag. We will 
have to change all of the numbers. If you would like to make this rectangular image square, you should 
fnd the width and height from the Get Image Informaton Quickie. Use the smallest of the two lengths 
to determine the size of the square. In my 300 x 225 pixel image, the largest square I can get is 225 x 225 
pixels, and I will need to make sure the Y origin is 0. At that point, I use the image and the squares to get 
the best part of the image for the area. The upper right and lower lef crop squares will move the 
marked area. The other two (upper lef and lower right) will change the dimensions of the marked area, 
so be careful. I have a screenshot of this, right afer I fxed the width and height and the Y origin, but 
before the fnal positoning. The arrows show the move points. 

I decided that the image looked the best with the X Origin at 42. The fnal image appears here. 

Find Info About Your Image

This window will tell you the pixel lengths. Right click on the image and follow <Image> View -> Info 
Window... Here is a screenshot of a calculator which also gives lots of good informaton. I got another 
image from APOD It is prety big. (Not as big as Saturn though) You can see in the dialog above, it is 2241 
x 1548 pixels. 

If you are just making a square out of a rectangle, like in the Crop An Image Quickie, you need only to 
open the dialog and fnd the lesser length and use that as described. Since this is very litle informaton, 
and defnately not enough to fll the space between the menu thumbnail and the dialog screenshot in 
my layout, I thought I would run through some calculator exercises that might help you to meet your 
image needs. 

It is nice to have images appear on a browser window as a photo would. Photos online appear to be 4x6 
inches when scaled to 288x432 pixels (72 dpi for many monitors). There is a problem, however, if you try 
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to scale this image. The rato of width to length of the original does not match the rato of the photo. So, 
to make the scaled image the correct size crop 10 pixels from the height. For the sample image, it was 
best to crop 10 pixels of from the top. The fnal image should "appear" as a 6x4 inch photo on most 
monitors. 

There will be problems whenever mixing scanned photos with digital photos and also with scanned 
negatves. Modern flm developing machines automatcally crop one half of an inch of from each image 
-- the rumor is that the photo printng machines match a certain style of camera view. If you are 
preparing an image to be printed on a machine like this; or if you are planning on a gallery where the 
images are from diferent sources, some intelligent cropping to ft the best size for the medium you have 
chosen will be a plus. If this is confusing; please blame the photo printng industry and not GIMP. 

You can change the Resoluton of your image as well, using the same methods as we used in the Scale, 
although, in my somewhat limited use, the issue is more about how many pixels. Let's say you want to 
get this image printed at the photo lab. 300 pixels for every inch is preferred. This original image will 
print easily as a 7 x 5 photo. 2241px/300ppi = 7.47in. Get out your calculator for the short side. 
1548/300 = _. 

There is another brutal fact you should come to terms with if you are new to graphics and computers. 
Just because it looks good on the screen (the image from before) doesn't mean that it will print that 
nicely. I tried to emulate how this image would appear printed at 300dpi here. Sorry. There are some 
optons, for instance my friend printed images and then scanned them back in. Terrible business! 

Change the Mode

As with anything else, images come in diferent kinds and serve diferent purposes. Sometmes, a small 
size is important (for web sites) and at other tmes, retaining a high colour depth in all its glory (a family 
portrait) is what you want. GIMP can handle all of this, and more, primarily by convertng between three 
fundamental modes, as seen in this menu. In order to switch your image to one of these modes, you 
open it and follow that menu and click the mode you want.
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RGB - This is the default mode, used for high quality rich colour images. This is also the mode to do most 
of your image work with including scaling, cropping and even fipping as it gives the computer more 
informaton to work with. This extra informaton also makes RGB Mode the largest to store as a result.

A litle bit of detail if you are interested. Each pixel or point when in this mode consists of three diferent 
components. R->Red, G->Green, B->Blue. Each of these in turn can have an intensity value of 0-255. So, 
at every pixel, what you see is an additve combinaton of these three components. All these 
combinatons result in a way to represent millions of colours.

As an example to practce with images have been provided in various sizes and formats. Indexed images 
of diferent sizes: from a very old APOD a small gif and a larger gif of the same image from a later APOD. 
Also the same image in RGB as provided by Earth Observatory a smaller version and a huge version.

Indexed - This is the mode usually used when fle size is of concern, or when you are working with 
images with few colours. It involves using a fxed number of colours, 256 or less, at each point to 
represent the colour at that point. GIMP defaults to atemptng to fgure out an "optmum palete" to 
best represent your image. Try it, you can undo it if you don't like the results, or use a custom palete or 
more colours.

As you might expect, since the informaton needed to represent the colour at each pixel is less, the fle 
size is a lot smaller. However, sometmes, there will be optons in the various menus that seem to have 
been "greyed" out for no apparent reason. This usually means the flter or opton cannot be applied 
when your image is in its current mode. Changing the mode to RGB as outlined above should solve this 
issue. If that doesn't work either, perhaps the opton you're trying requires your layer to have the ability 
to be transparent. This can be done just as easily via (Image)->Layer->Transparency->Add Alpha 
Channel.
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Grayscale - In case you want to convert your brilliant colour image to something that's black and white 
(with a lot of shades of grey), this is one of the easiest ways in which to do it. Some photos do look a lot 
fancier when displayed in grayscale. Again, if you're interested in some detail, this is achieved by taking 
the RGB values at the pixels in your image, and suitably weighted averaging them to get an intensity at 
that point.

There is no need to convert an image to a specifc mode before saving it in your favourite format, as 
GIMP is smart enough to export.

Flip An Image
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When you need the person in the photo looking in the other directon, or you need to top of the image 
to be the botom. Mirroring the image (sort of). Right click on the image and follow the menus <Image> 

Tools -> Transform Tools -> Flip, or use the buton on the toolbox. 

Using another APOD image I demonstrated all of the fips on this image. You might get bored before it is 
over .... 

The tool used as is (the default) will do this to an image. 

If you double click on the buton, up will pop the means to fip images vertcally as well. I did just that on 
this image. 

For a really big fnish, I fipped this image both ways. At least it is such a cool image for all of this silliness. 

The fips are all displayed on one page for you, here. One might ask themselves, useful? or fller for a 
pre-established format? 

Rotate An Image

Let's say you turned your brand new digital camera to get a vertcal shot, now some of your images are 
on their sides. Right click on the image, and follow the menus <Image> Image -> Transforms -> Rotate -> 
90 degrees (or 270 depending on the orientaton). Using an APOD image. I rotated it once to 
demonstrate. 90 degrees CCW. 
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